Frequently Asked Questions / Anveo Mobile App / Anveo Delta Server Install Failed

Anveo Delta Server Install Failed

Symptom

Anveo Delta Server cannot be installed in Anveo Setup in Microsoft Dynamics showing one of the following error messages.

  • User does not have permission to perform this action.
  • CLR is disabled on the SQL Server. Activate CLR and try again.

Cause

The SQL server user does not have permission to run the RECONFIGURE statement showing the following error message:

Solution 1 – Give “sysadmin” Rights Before Installation

  • Open SQL Server Management Stuido and give your SQL user sysadmin rights for the installation.

A) For Dynamics 2013 and newer, the service user of the Microsoft Dynamics Server is used. Default is NETWORK SERVICE.

Set-up sysadmin right in SQL Server Management Studio:

B) For Microsoft Dynamics NAV 2009 R2, the SQL Server user is the user that you have set-up in Anveo Setup.

C) All Microsoft Dynamics versions: If you have set-up a dedicated user in function GetSQLConnectionInformation in codeunit ACF App Events, give the sysadmin rights for this user.

  • Re-run Anveo Delta Server installation.
  • For security reasons, remove syadmin rights for the user after installation.

Solution 2 – Enable CLR manually in SQL Server Management Studio

(Anveo Client Suite 6.01 and newer)

  1. Open SQL Server Management Studio with a user with sysadmin rights.
  2. Run the following Query:
sp_configure 'clr enabled', 1; RECONFIGURE;