Frequently Asked Questions / Anveo Mobile App / Health Check Failed on AnveoClientSuite.dll Version

Health Check Failed on AnveoClientSuite.dll Version

Symptom

Anveo’s Health Check fails on AnveoClientSuite.dll test showing an error message like:

AnveoClientSuite.dll Version… Failed: Required version of AnveoClientSuite.dll is … Detected version is …

Causes

  1. AnveoClientSuite.dll is not installed yet.

  2. All Anveo Client Suite components must fit together. In this case, Objects in Microsoft Dynamics and AnveoClientSuite.dll is not a valid pair.

Solution

Copy the correct version of AnveoClientSuite.dll in your Add-ins folder of your Microsoft Dynamics installation. Restart Microsoft Dynamics web services afterwards and re-run your test.

Note: This article is for Anveo Client Suite 6 and newer.