Bloqueo dinámico del servidor NAV durante la sincronización de SAVEASPDF (NAV2013)
Síntoma
En algunas instalaciones de Anveo Mobile App que utilizan Microsoft Dynamics NAV 2013 (no R2), el servidor de Microsoft Dynamics NAV se bloquea usando la función SAVEASPDF durante el proceso de sincronización, mientras que SAVEASPDF está funcionando correctamente fuera de Anveo.
Causa
Esto es causado por un error interno en Microsoft Dynamics NAV, mostrando el clr.dll como la razón en el Registro de Eventos de Windows.
Solución
Descargue una versión actualizada del complemento WebServiceHelper.dll de los archivos de lanzamiento del Portal de socios de Anveo, detenga los servicios web de Microsoft Dynamics NAV, sustituya el archivo en la carpeta AddIn e inicie los servidores Microsoft Dynamics NAV.
Nota
La versión actualizada es necesaria sólo para Microsoft Dynamics NAV 2013 (no para R2). Sin embargo, el Anveo Health Check arrojará un mensaje de error en las versiones de dll que no se ajusten. Está bien ignorar estos mensajes.