Preguntas Frecuentes / Anveo Mobile App / Error en la instalación de Anveo Delta Server
Esta es una traducción automática. El mensaje original está disponible en Inglés.

Error en la instalación de Anveo Delta Server

Síntoma

Anveo Delta Server no se puede instalar en Anveo Setup en Microsoft Dynamics mostrando uno de los siguientes mensajes de error.

  • El usuario no tiene permiso para realizar esta acción.
  • CLR está desactivado en el servidor SQL. Active el CLR y vuelva a intentarlo.

Causa

El usuario del servidor SQL no tiene permiso para ejecutar la sentencia RECONFIGURE que muestra el siguiente mensaje de error:

Solución 1 – Otorgar derechos de «administrador de sistemas» antes de la instalación

  • Abra SQL Server Management Stuido y dé a su usuario SQL los derechos de administrador de sistemas para la instalación.

A) Para Dynamics 2013 y posteriores, se utiliza el usuario de servicio de Microsoft Dynamics Server. El valor predeterminado es SERVICIO DE RED.

Configure el administrador de sistemas en SQL Server Management Studio:

B) Para Microsoft Dynamics NAV 2009 R2, el usuario de SQL Server es el usuario que ha configurado en Anveo Setup.

C) Todas las versiones de Microsoft Dynamics: Si ha configurado un usuario dedicado en la función GetSQLConnectionInformation en codeunit ACF App Events, proporcione los derechos de administrador de sistemas para este usuario.

  • Vuelva a ejecutar la instalación de Anveo Delta Server.
  • Por razones de seguridad, elimine los derechos syadmin para el usuario después de la instalación.

Solución 2 – Habilitar CLR manualmente en SQL Server Management Studio

(Anveo Client Suite 6.01 y posteriores)

  1. Abra SQL Server Management Studio con un usuario con derechos de administrador de sistemas.
  2. Ejecute la siguiente consulta:
sp_configure 'clr enabled', 1; RECONFIGURE;