Foire aux questions / Anveo Mobile App / La réplication d’utilisateur échoue avec l’erreur Anveo Server « Unauthorized ».
C'est une traduction automatique. Le message original est disponible en Anglais.

La réplication d’utilisateur échoue avec l’erreur Anveo Server « Unauthorized ».

Symptôme

La réplication des utilisateurs Anveo dans la configuration d’Anveo échoue. Le journal du serveur Anveo affiche le message d’erreur « Non autorisé ».

Cause

  • Nom d’utilisateur, nom de domaine ou mot de passe sont incorrects.
  • L’utilisateur n’est pas configuré en tant qu’utilisateur Dynamics NAV ou ne dispose pas des droits Dynamics NAV.
  • Anveo Server n’est pas à NTLM = true.
  • Le service Web n’est pas réglé sur NTLM = true.
  • VNI 2009 seulement : La délégation n’est pas mise en place correctement.

Solution

  • Ouvrez votre service Web à l’aide de http://yourservername/DynamicsNAV/WS/Services en utilisant votre nom de domaine, votre nom d’utilisateur et votre mot de passe avec Internet Explorer et testez vos identifiants.
    DomainUser
    Note : DynamicsNAV est le nom d’instance de votre service web Dynamics. Il peut être différent comme DynamicsNAV70 ou DynamicsNAV80.
  • Réglez Anveo Server sur NTLM true
  • Définissez le Service Web sur NTLM true et redémarrez le Service Web.
    Note pour l’ANR 2009 : Arrêtez Dynamics NAV Server et Web Service d’abord, puis relancez les services. Ne redémarrez pas les deux services directement.
  • VNI 2009 seulement : Essayez d’abord d’utiliser les services Web sans délégation. Configurez le service web sur votre serveur SQL.