Foire aux questions / Anveo Mobile App / L’application affiche « Aucun utilisateur trouvé » lors de la première connexion.
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L’application affiche « Aucun utilisateur trouvé » lors de la première connexion.

Symptôme

Lors de votre première connexion avec votre appareil mobile, Anveo Mobile App affiche un message d’erreur Aucun utilisateur trouvé.

Cause

Anveo Server ne possède aucune information sur les utilisateurs d’Anveo Mobile App Ceci est dû à un problème de configuration.

Anveo Server ne peut pas communiquer avec le service web Dynamics pour demander des utilisateurs pour différentes raisons :

  • URL de service Web Dynamics erronée
  • un paramètre de pare-feu qui refuse l’accès du serveur Anveo au service web Dynamics
  • nom d’utilisateur et mot de passe incorrect de l’utilisateur Dynamics qui est utilisé dans le fichier de configuration d’Anveo Server.
  • la société par défaut a tort ou l’utilisateur n’a pas suffisamment d’autorisation NAV pour accéder à cette société.
  • Le service Web n’est pas actif pour les codeunits Task_Communication ou Web_Communication.
  • Le service Web n’autorise pas NTLM.
  • En raison des différents jeux de caractères, les caractères spéciaux ne sont parfois pas autorisés dans les mots de passe. N’utilisez que des caractères de base.
  • L’enregistrement du serveur ou de l’utilisateur est activé, mais le dossier d’enregistrement n’existe pas ou n’a pas suffisamment de permissions.

Solution

Vérifiez que la raison d’un problème de communication est le fichier journal d’Anveo Server.
Vous trouverez ce fichier dans le dossier TransfertANVEOServiceTierLog
Recherche pour « SyncAllAnveoUsers automatically was not successful Exception :
A la fin de cette ligne, vous verrez le message d’erreur détaillé.

Ensuite, vérifiez les paramètres de vos services Web dans le fichier Anveo Service Tier.exe.config.

Essayez d’ouvrir votre service web dans votre navigateur à partir de votre serveur exécutant Anveo Server en utilisant h
ttp://servername:7047/DynamicsNAV80/WS/Services Vous devriez obtenir le résultat suivant : Les cases rouges remplacent le nom de votre instance.

Si vous ne voyez pas cet écran, c’est que vos services Web ou votre utilisateur NAV ne sont pas correctement configurés.

Si vous obtenez un résultat, mais que vous ne pouvez pas voir Task_Communicaton ou Web_Communication, activez les services Web pour Anveo dans Anveo Client Suite setup :

Vérifiez votre fichier de configuration des Services Web, NTLM doit être activé. Redémarrez les services Web après avoir apporté des modifications.