Foire aux questions / Anveo Mobile App / L’application ne s’initialise pas en affichant « Téléchargement de données » de façon permanente.
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L’application ne s’initialise pas en affichant « Téléchargement de données » de façon permanente.

Symptôme

Lors de la première connexion, l’Anveo Mobile App est en cours de téléchargement des données. Aucun traitement de données n’est affiché, juste un téléchargement.

Dans le sous-dossier TransferOUT, vous pouvez voir de nouveaux fichiers zip à chaque connexion.

Cause

Anveo Mobile utilise deux canaux de communication : Le premier est un canal de communication utilisant le port par défaut 7020. Le second est un canal de transfert de données utilisant le port par défaut 7021.

Vous obtiendrez cette erreur si le premier canal de communication fonctionne, mais que le canal de données n’est pas correctement configuré.

Raisons possibles de cette erreur :

  • Le pare-feu est configuré pour le canal de communication (7020), mais pas pour le canal de données (7021).
  • Le canal de données (7021) utilise https, mais il n’est pas configuré pour votre certificat SSL.
  • Anveo Server ne peut pas créer le socket 7021 en raison de droits manquants. Vous obtiendrez un message d’erreur dans le journal d’Anveo Server.

Comme Anveo Server ne peut pas envoyer de données, les fichiers zip restent dans le dossier TransferOUT.

Solution

Vérifiez les paramètres de votre pare-feu pour le mappage des canaux de données.

Ré-exécutez l’enregistrement https pour le port de canal de données.
Ouvrez le dossier TransferANVEOServiceTierLog et (re)exécutez le fichier ANVEOServiceTier.bat avec les droits d’administrateur.

Si vous avez déjà enregistré un autre certificat SSL pour ce port tcp, supprimez d’abord votre enregistrement :
netsh http del urlacl url=https://*:7021/
netsh http del sslcert ipport=0.0.0.0.0:7021 

Ensuite, réexécutez ANVEOServiceTier.bat avec les droits d’administrateur.

Certains périphériques nécessitent un redémarrage de l’appareil après avoir modifié un certificat. Ceci est causé par un cache de certificat sur le périphérique.

Donnez à l’utilisateur le droit de créer une prise sur le port 7021. Le rôle d’administrateur local a le droit de le faire.