Foire aux questions / Anveo Mobile App / Message « Un filtre de sécurité a été appliqué à la table Company. Vous ne pouvez pas accéder aux enregistrements qui sont en dehors de ce filtre. »
C'est une traduction automatique. Le message original est disponible en Anglais.

Message « Un filtre de sécurité a été appliqué à la table Company. Vous ne pouvez pas accéder aux enregistrements qui sont en dehors de ce filtre. »

Symptôme

Pendant l’initialisation ou la synchronisation, le message d’erreur suivant s’affiche :

« Dynamique : Un filtre de sécurité a été appliqué à la table Compagnie. Vous ne pouvez pas accéder aux enregistrements qui sont en dehors de ce filtre. »

Cause

Vous avez configuré un filtre de sécurité sur la table de la société pour votre utilisateur Microsoft Dynamics dans la configuration de sécurité Microsoft Dynamics pour restreindre la vue des utilisateurs. Toutefois, certaines tâches Anveo interactives nécessitent l’accès à tous les noms de société, ce qui se traduit par ce message d’erreur.

Les solutions

  • Après avoir modifié la définition de l’Anveo Mobile App, exécutez « Update all Delta Script » dans « Anveo Setup ». Il s’agit d’une tâche administrative importante qui doit être effectuée par un utilisateur Microsoft Dynamics et qui ne peut pas être effectuée automatiquement par l’utilisateur distant pendant l’initialisation ou la synchronisation.
  • Si vous avez trop de périphériques utilisateur enregistrés pour un utilisateur, supprimez les périphériques non requis dans Microsoft Dynamics. La suppression automatique – si elle est activée – n’est pas prise en charge dans ce cas.