Domande frequenti / Anveo Mobile App / L’applicazione mostra “Nessun utente trovato” al primo accesso.
Questa è una traduzione automatica. Il messaggio originale è disponibile in Inglese.

L’applicazione mostra “Nessun utente trovato” al primo accesso.

Sintomo

Al tuo primo login con il tuo dispositivo mobile, Anveo Mobile App mostra un messaggio di errore Nessun utente trovato.

Causa

Anveo Server non ha informazioni sugli utenti di Anveo Mobile App. Questo è causato da un problema di configurazione.

Anveo Server non può comunicare con il servizio web Dynamics per chiedere agli utenti per diverse ragioni:

  • URL errata del servizio Web Dynamics Web Service
  • un’impostazione firewall che nega l’accesso da Anveo Server al servizio web Dynamics
  • nome utente e password dell’utente Dynamics utilizzati nel file di configurazione di Anveo Server.
  • l’azienda predefinita è sbagliata o l’utente non ha abbastanza permesso NAV per accedere a questa azienda.
  • Il servizio Web non è attivo per codeunits Task_Communication o Web_Communication.
  • Il servizio web non permette NTLM.
  • A causa dei diversi set di caratteri, a volte i caratteri speciali non sono ammessi nelle password. Utilizzare solo caratteri di base.
  • La registrazione del server o dell’utente è attivata, ma la cartella di registrazione non esiste o non ha permessi sufficienti.

La soluzione

Verificare che la causa di un problema di comunicazione sia il file di log di Anveo Server.
Troverete questo file nella cartella TransferANVEOServiceTierLog
Ricerca per “SyncAllAnveoUsers automaticamente non ha avuto successo Eccezione:
Alla fine di questa riga viene visualizzato il messaggio di errore dettagliato.

Quindi, controllare le impostazioni del servizio web nel file Anveo Service Tier.exe.config.

Prova ad aprire il tuo servizio web nel tuo browser dal tuo server che esegue Anveo Server utilizzando h
ttp://servername:7047/DynamicsNAV80/WS/Services Dovresti ottenere il seguente risultato: Le caselle rosse sostituiscono il nome dell’istanza.

Se non è possibile visualizzare questa schermata, i servizi web o l’utente NAV non sono configurati correttamente.

Se si ottiene un risultato, ma non è possibile visualizzare Task_Communicaton o Web_Communication, attivare i servizi Web per Anveo nella configurazione di Anveo Client Suite:

Controllare il file di configurazione dei Web Services, NTLM deve essere abilitato. Riavviare i servizi web dopo aver apportato delle modifiche.