Veelgestelde vragen / Anveo Mobile App / App toont “Geen gebruikers gevonden” bij de eerste login.
Dit is een automatische vertaling. De originele post is beschikbaar in Engels.

App toont “Geen gebruikers gevonden” bij de eerste login.

Symptomen

Bij uw eerste login met uw mobiele apparaat toont Anveo Mobile App een foutmelding Geen gebruikers gevonden.

Oorzaak

Anveo Server heeft geen informatie over gebruikers van Anveo Mobile App. Dit wordt veroorzaakt door een configuratieprobleem.

Anveo Server kan om verschillende redenen niet communiceren met Dynamics web service om gebruikers te vragen:

  • verkeerde Dynamics Web Service URL
  • een firewall die de toegang van Anveo Server tot Dynamics web service ontzegt
  • verkeerde gebruikersnaam en wachtwoord van Dynamics gebruiker die gebruikt wordt in het configuratiebestand van Anveo Server.
  • standaard bedrijf is verkeerd of de gebruiker heeft niet genoeg NAV toestemming om toegang te krijgen tot dit bedrijf.
  • Webservice is niet actief voor codeunits Task_Communication of Web_Communication.
  • Webservice staat NTLM niet toe.
  • Vanwege verschillende karaktersets zijn speciale tekens soms niet toegestaan in wachtwoorden. Gebruik alleen basiskarakters.
  • Server- of gebruikerslogging is ingeschakeld, maar de logmap bestaat niet of heeft onvoldoende rechten.

Oplossing

Controleer de reden van een communicatieprobleem is het Anveo Server Log bestand.
U vindt dit bestand in de map ☺☺☺Transfer
IederenanVEOServiceTierLog Search for “SyncAllAnveoUsers was automatisch niet succesvol Uitzondering:
Aan het einde van deze regel ziet u de gedetailleerde foutmelding.

Controleer vervolgens uw web service instellingen in Anveo Service Tier.exe.config bestand.

Probeer uw webservice in uw browser te openen vanaf uw server met Anveo Server via h
ttp://servername:7047/DynamicsNAV80/WS/Services Het volgende resultaat moet u krijgen: De rode vakjes vervangen de naam van uw instantie.

Als u dit scherm niet kunt zien, zijn uw webservices of uw NAV-gebruiker niet goed ingesteld.

Als u een resultaat krijgt, maar u Task_Communicaton of Web_Communication niet kunt zien, activeert u webservices voor Anveo in de Anveo Client Suite setup:

Controleer uw Web Services configuratiebestand, NTLM moet ingeschakeld zijn. Start de webservices opnieuw op nadat u wijzigingen hebt aangebracht.