Najczęściej zadawane pytania / Anveo Mobile App / Niepowodzenie instalacji serwera Anveo Delta
Jest to tłumaczenie automatyczne. Pierwotne stanowisko jest dostępne w angielski.

Niepowodzenie instalacji serwera Anveo Delta

Symptom

Serwer Anveo Delta nie może być zainstalowany w Anveo Setup w Microsoft Dynamics pokazującym jeden z poniższych komunikatów o błędach.

  • Użytkownik nie ma uprawnień do wykonania tej czynności.
  • CLR jest wyłączony na serwerze SQL. Aktywuj CLR i spróbuj ponownie.

Przyczyna

Użytkownik serwera SQL nie ma uprawnień do uruchamiania instrukcji RECONFIGURE pokazującej następujący komunikat o błędzie:

Rozwiązanie 1 – Nadać „sysadminowi” prawa przed instalacją

  • Otwórz SQL Server Management Stuido i nadaj użytkownikowi SQL prawa sysadmin do instalacji.

A) Dla Dynamics 2013 i nowszych używany jest użytkownik usługi Microsoft Dynamics Server. Domyślnie jest to usługa NETWORK SERVICE.

Konfiguracja sysadmin bezpośrednio w SQL Server Management Studio:

B) Dla Microsoft Dynamics NAV 2009 R2, użytkownik SQL Server jest użytkownikiem, który został skonfigurowany w Anveo Setup.

C) Wszystkie wersje Microsoft Dynamics: Jeśli skonfigurowałeś dedykowanego użytkownika w funkcji GetSQLConnectionInformation w codeunit ACF App Events, nadaj uprawnienia administratora dla tego użytkownika.

  • Ponownie uruchomić instalację serwera Delta Anveo.
  • Ze względów bezpieczeństwa należy usunąć uprawnienia syadminy dla użytkownika po instalacji.

Rozwiązanie 2 – włączenie CLR ręcznie w SQL Server Management Studio

(Anveo Client Suite 6.01 i nowszy)

  1. Otwórz SQL Server Management Studio z użytkownikiem z prawami sysadmin.
  2. Uruchom następujące zapytanie:
sp_configure 'clr enabled', 1; RECONFIGURE;