Häufig gestellte Fragen / Anveo Mobile App / Anveo Server startet nicht mit der Meldung „Error 15010: Configuration error“.
Diese Seite wurde automatisch übersetzt. Ursprünglich wurde der Inhalt auf Englisch verfasst.

Anveo Server startet nicht mit der Meldung „Error 15010: Configuration error“.

Symptom

Beim Start des Anveo-Servers erscheint eine Fehlermeldung mit der Aufschrift Error 15010: Configuration error.“

Ursachen

Dieses Verhalten kann durch verschiedene Konfigurationsprobleme verursacht werden. Im Folgenden finden Sie mehrere mögliche Ursachen und Lösungen.
Die Ursache finden Sie in der Anveo Server Log-Datei, die automatisch im Unterordner TransferANVEOServiceTierLog angelegt wird. Wenn kein Protokoll im Protokollordner verfügbar ist, öffnen Sie bitte den Windows Event Viewer für weitere Informationen.

Ursache 1 – Fehlende Rechte

Der Dienst hat keinen Benutzer mit lokalen Administratorrechten. Im Windows-Ereignisprotokoll finden Sie folgende Fehlermeldung:
Dienst kann nicht gestartet werden. System.Exception: HTTP konnte die URL http….. nicht registrieren.

Lösung 1

Geben Sie dem Benutzer für den Anveo-Dienst Windows-Administratorrechte für den lokalen Computer.

Ursache 2 – Zertifikat nicht gefunden

Fehlermeldung: SSL Config Processing Exception:could not find your certificate
Wenn Sie Ihr eigenes Zertifikat verwendet haben, kann der Anveo Server Ihr Zertifikat nicht finden.

Lösung 2

Überprüfen Sie Ihren Thumbprint in Ihrer Konfigurationsdatei:

Der Thumbprint muss genau so sein, wie er in Ihrem Zertifikat angegeben ist.

Zertifikat-Snap-In hinzufügen:

Öffnen Sie Ihr Zertifikat:

Vergleichen Sie Ihren Thumbprint hier mit Ihrer Einstellung in der Anveo Server-Konfigurationsdatei.

Wenn Sie den Wert mit Copy&Paste übertragen haben, achten Sie darauf, dass am Anfang oder am Ende des Thumbprints kein verstecktes Zeichen steht.