Häufig gestellte Fragen / Anveo Mobile App / Init oder Sync schlägt mit Fehler fehl „Der folgende SQL-Fehler kam unerwartet. Ein.NET Framework-Fehler ist aufgetreten“…..
Diese Seite wurde automatisch übersetzt. Ursprünglich wurde der Inhalt auf Englisch verfasst.

Init oder Sync schlägt mit Fehler fehl „Der folgende SQL-Fehler kam unerwartet. Ein.NET Framework-Fehler ist aufgetreten“…..

Symptom

Während der Initialisierung oder Synchronisierung zeigt die Anveo Mobile App eine Fehlermeldung an:

Bei der Verarbeitung in Dynamics NAV ist folgender Fehler aufgetreten: Der folgende SQL-Fehler war unerwartet. Bei der Ausführung der benutzerdefinierten Routine oder des Aggregats „UDP_Build_ANVEODELTA“ ist ein.NET Framework-Fehler aufgetreten: System.Data.SqlClient…..

Ursache

Der Anveo Delta Server kann keine Daten für den Benutzer erstellen. Dies kann auf verschiedene Ursachen zurückzuführen sein:

  • Die Eigenschaft Convert Characters ist im Anveo Client Suite Setup nicht korrekt eingerichtet.
  • Ein Filter in Ihrem Synchronisationspaket ist nicht gültig.
    Zum Beispiel: Filtern Sie nicht nach Daten für -3M….
    Verwenden Sie nur die zulässige Syntax, wie %-3M….
  • Es kann keine Tabelle gefunden werden, die in Ihrem Synchronisationspaket verwendet wird.
  • Der Anveo Delta Server kann keine Daten vom SQL-Server lesen.
  • Ein Integer- oder Dezimalfeld ist zu groß (angezeigt als System.OverflowException in der Protokolldatei).

Diese Fehlermeldung zeigt nur an, dass bei der Datenverarbeitung im Anveo Delta Server auf SQL Server etwas schief geht. Sie können die Details des Fehlers nicht ohne weitere Protokollierung sehen.

Wenn Sie diese Fehlermeldung erhalten, sind grundlegende Einstellungen wie Servername, Ports und Firewall-Einstellungen bereits korrekt. Ändern Sie sie nicht.

Lösung

  • Schalten Sie die detaillierte Protokollierung für den Anveo-Benutzer ein und führen Sie die Initialisierung oder Synchronisierung erneut durch. Informationen zur Einrichtung der Protokollierung finden Sie in der Dokumentation der Anveo Client Suite. Suchen Sie nach Logging Level und Server Log.
  • Suchen Sie nach der größten Textdatei in Ihrem Protokollierungsordner und öffnen Sie sie in Ihrem Texteditor. Suchen Sie nach der folgenden Fehlerart:
  • Beispiel 1
    Der folgende SQL-Fehler war unerwartet.
    Bei der Ausführung der benutzerdefinierten Routine oder des Aggregats „UDP_Build_ANVEODELTA“ ist ein .NET Framework-Fehler aufgetreten:
    System.Data.SqlClient.SqlException: Falsche Syntax bei’M‘.
    System.Data.SqlClient.SqlException:
    > Verursacht durch falsche Syntax bei Filtern.
  • Beispiel 2
    Ungültiger Objektname ‚CRONUS International Ltd.$Country/Region_ANVEODATA
    > Verursacht durch falsche Werte in Convert Characters. Lesen Sie die Installationsdokumentation, was Sie hier eingeben müssen.
  • Beispiel 3
    Die aktuelle Transaktion kann nicht bestätigt werden und unterstützt keine Operationen, die in die Protokolldatei schreiben. Rollback der Transaktion.
    > Einige Anveo-Versionen erfordern ein COMMIT in der Codeunit ACF App Events – OnSyncRequest:
  • Beispiel 4
    Die SELECT-Berechtigung wurde für das Objekt’ACF Anveo Page_ANVEODATA‘ verweigert…..
    > Der Anveo Delta Server verfügt nicht über ausreichende Rechte zum Lesen von Daten. Bitte kontaktieren Sie unser Support-Team.
  • Beispiel 5
    Anveo Delta Server kann aufgrund von Zeichencodierungsproblemen oder fehlenden Rechten keine Daten lesen. Bitte lesen Sie die detaillierte Fehlermeldung.

In dieser Protokolldatei erhalten Sie die Details des SQL-Fehlers.

Hinweis: Diese Liste enthält nur einige exemplarische Fehler. Ihre Fehlermeldung kann unterschiedlich sein.

Beheben Sie den Fehler und führen Sie die Initialisierung oder Synchronisierung erneut durch.