App shows on login or on sync: “Dynamics NAV: Synchronization is currently not available. Please try again later.”…
Symptom
On first login or on synchronization, Anveo Mobile App shows an error message Dynamics NAV: Synchronization is currently not available. Please try again later. …


Cause
- Anveo User does not have any Synchronization Packages assigned.
- One of the users synchronization packages are deactivated.
- Default company not set
- No role set for the user
- Role is set to a wrong-spelled company name
- Delta Scripts not up to date
Solution
- Assign one or more Synchronization Packages to your user.
- Activate all Synchronization Packages (that are used for the user)

- Set default company in Anveo User
- Assign a role for Anveo User and synchronize Anveo User rights
- Check the company name used in Anveo User role
- Recreate Anveo Delta Scripts in Anveo Setup