Frequently Asked Questions / Anveo Mobile App / Message “A security filter has been applied to table Company. You cannot access records that are outside of this filter.”

Message “A security filter has been applied to table Company. You cannot access records that are outside of this filter.”

Symptom

During initialization or synchronization, you see the following error message:

“Dynamics: A security filter has been applied to table Company. You cannot access records that are outside of this filter.”

Cause

You have set up a security filter on the company table for your Microsoft Dynamics user in Microsoft Dynamics security setup to restrict the users’ view. However, some interal Anveo tasks require access to all company names which results in this error message.

Solutions

  • After making any changes in the Anveo Mobile App definition, run “Update all Delta Script” in “Anveo Setup”. This is an important administrative tasks that must be done by a Microsoft Dynamics user and can’t be done automatically by the remote user during init or sync.
  • If you have too many user devices registered for a user, delete the unrequired devices in Microsoft Dynamics. The automatic deletion – if activated – is not supported in this case.