Frequently Asked Questions / Anveo Mobile App / User Replication fails with error message “AnveoDynamicLinkLibrary”… “SetSX4000V3” or “Internal Server Error”

User Replication fails with error message “AnveoDynamicLinkLibrary”… “SetSX4000V3” or “Internal Server Error”

Symptom

Anveo User replication fails in Anveo Client Suite Set-Up with an error message AnveoDynamicLinkLibrary.DynamicLinkLibraryClass.SetSX4000V3 failed with this message: The requested failed with HTTP status 404: Not found.
Or a similar message.

Or in Dynamics NAV 2009 Classic Client you get Internal Server Error:

Cause

Anveo also tries to replicate Anveo Users to Anveo Web Portal, but this connection fails.

Solution

If you are not using Anveo Web Portal, remove setting Anveo Web Store URL in Anveo Client Suite Setup:

or

If you are using Anveo Web Portal, test if you have entered Anveo Web Store URL correctly and IIS and Anveo Web Store Application Pool is started.