Config / Getting Started / Upgrade

Upgrade

Anveo EDI Connect uses a versioning scheme, where we have a major, a minor and a revision number, like 4.00.01 (Version: 4, minor version: 00, revision 01). The upgrade procedure is explained below. There is a knowledge base article on whether you should upgrade the module in an existing live system. The module revision update is considered secure, but you still need to test the system after an upgrade.

In this section we will show the upgrade instructions based on the selected module version above. Please make sure to select the correct version first.

Before starting any update, please make sure to backup the EDI mappings and objects. Please always try a new version first in a test environment. If you plan to update a live environment, please contact our support beforehand, to ensure that they have resources available in case you need help.

FOB-Installation

This section does not apply, if you’re using the Extension version of our module for Business Central.

If you are upgrading from a version prior to 1.47, please check if there is a table called “EDI Version Branch” and delete the table data and object before updating to a newer version.

You can import the new objects, but be careful not to overwrite your customizations. You do not have to import the codeunit EDI Callback as there is a second codeunit 5327313 EDI Callback - Template that is shipped with Anveo EDI Connect. If we add a function to the EDI Callback codeunit we will also add it to the template. You can simply copy new functionality from the 5327313 EDI Callback - Template codeunit to your EDI Callback codeunit. The EDI callback codeunit itself has not changed from 1.47 to 4.00. But there are some new helper functions available to access function parameters.

If you are using the remote communication components, please re-install them, in case they have changed.

After an upgrade, please run the compile command from the development environment for all EDI objects (object ID “5327300” to “5327399”). If you get errors due to missing automations/.NET Dlls you can ignore them, if you do not need the functionality:

  • Remote Communication
    • file transfer via ftp/ftps, email
  • ZUGFeRD
    • special PDF invoices

After updating the objects, please open the EDI Setup window. You might be asked to restart the client or update the EDI mapping data. Please follow the instructions on the screen. If you are using a NAS (NAV Application Server) you might also need to restart it.

Depending of the upgrade, there might also be a lot of new properties in the EDI mappings. The EDI mappings will upgrade automatically, but you should check each mapping after the upgrade.

Please refer back to this section if you get a newer version of the objects and documentation to check if there are additional steps required.

Testing the Module after an Upgrade

After each upgrade, you should ensure that the EDI mappings still behave like expected. If there are API changes or the converter will behave different (only on major upgrades), we will document them in our changelog. We do not expect any issues after a minor or revision upgrade, but we only have a limited amount of test cases. It is your responsibility to ensure that the module is behaving correctly after an upgrade.

We strongly recommend to try every update in a test system before upgrading a live system. A direct update of a live system always carries the risk that the EDI interfaces no longer function correctly. If the EDI data is business critical, this must be taken into account in the upgrade scenario. All relevant interfaces should be checked in a test system and there should be plans how to switch to the previous version if unforeseen difficulties should occur.