Config / Troubleshooting / Licensing

Licensing

Please make sure to select the correct version of the module and Dynamics above.

How to Get a License Key

See How to Get Anveo and Required Licensing Information

Extending the Dynamics License

If you do not see the Anveo EDI Connect objects, the module is probably not in your Microsoft Dynamics NAV 2013R2 license. Please ensure that the module is installed in the correct database and try to run the ANVEDI Setup Page from the Object Designer. If you get a permission error the module is not in your Dynamics license. Please contact your Dynamics NAV partner. More information on how to extend the license can be found here:

How to add Anveo to your Dynamics License

If you can open the page, but do not see the module in the menu, please make sure that the menu suite is installed and compile all menu suites, like described in the Installation chapter.

EDI License Error

To resolve license errors it is really important to understand which fields are used by the licensing check. You will find all the information in the EDI Setup card. More information on the EDI Setup.

The first information that is checked is, whether the license is still valid. You can find the information in the field License Expiry Date on the EDI Setup card.

If the license is expired, you’ll have to request a new license via your Dynamics NAV partner or at your sales contact at Anveo.

If the license is valid, the Used NAV Serial No. is checked against your license. Your Dynamics NAV partner will get the information, for which number the license was issued from our partner portal. If this number does not match, the module will not work. If the number shown in the field Used NAV Serial No. is the developer license number of your Dynamics NAV partner, he has to provide a correct partner key. Learn more about partner keys.

The next information checked is the shown Company Name against the one provided with the license. The values are case-sensitive. If the name provided with the license contains one of the following characters: “@”, “*”, “?”, the field Licensed Company Filter has to be filled with the value provided with the license. In this case the Company Name has to be within the provided filter. If the license does not contain one of those characters the field Licensed Company Filter has to be empty.

If you checked all those values and cannot find the issue, please make a screenshot of the License tab in the EDI Setup card. Please provide the exact error message and the screenshot to the EDI support team. Thank you!

WordPress Cookie Notice by Real Cookie Banner