La aplicación no inicializa mostrando «Downloading data» permanentemente.
Síntoma
En el primer inicio de sesión, la Anveo Mobile App se bloquea durante el proceso de descarga de datos. No se muestra ningún tratamiento de datos, sólo una descarga.


En la subcarpeta TransferOUT puede ver los nuevos archivos zip en cada inicio de sesión.
Causa
Anveo Mobile utiliza dos canales de comunicación: El primero es un canal de comunicación que utiliza el puerto por defecto 7020.El segundo es un canal de transferencia de datos usando el puerto por defecto 7021.
Obtendrá este error si el primer canal de comunicación funciona, pero el canal de datos no está configurado correctamente.
Posibles causas de este error:
- El cortafuegos está configurado para el canal de comunicación (7020), pero no para el canal de datos (7021).
- El canal de datos (7021) utiliza https, pero no está configurado para su certificado ssl.
- Anveo Server no puede crear el socket 7021 debido a la falta de derechos. Obtendrá un mensaje de error en el registro de Anveo Server.
Debido a que el Servidor Anveo no puede enviar datos, los archivos zip permanecen en la carpeta TransferOUT.
Solución
Compruebe la configuración de su cortafuegos para la asignación de canales de datos.
Vuelva a ejecutar el registro https para el puerto de canal de datos.
Abra la carpeta TransferANVEOServiceTierLog y vuelva a ejecutar el archivo ANVEOServiceTier.bat con derechos de administrador.
Si ya ha registrado otro certificado SSL para este puerto tcp, borre su registro primero:
netsh http del urlacl url=https://*:7021/
netsh http del sslcert ipport=0.0.0.0.0:7021

Después, vuelva a ejecutar ANVEOServiceTier.bat con derechos de Administrador.
Algunos dispositivos requieren que se reinicie el dispositivo después de cambiar un certificado. Esto se debe a la existencia de una caché de certificados en el dispositivo.
Dé al usuario el derecho de crear un socket en el puerto 7021. El rol de Administrador Local tiene el derecho de hacerlo.