Foire aux questions / Anveo Mobile App / Anveo Server ne démarre pas en affichant « Error 15010 : Erreur de configuration. »
This is an automatic translation. The original post is available in Anglais.

Anveo Server ne démarre pas en affichant « Error 15010 : Erreur de configuration. »

Symptôme

Au démarrage d’Anveo Server, un message d’erreur s’affiche et indique Error 15010 : Erreur de configuration. »

Causes

Ce comportement peut être causé par différents problèmes de configuration. Veuillez voir ci-dessous les multiples causes et solutions possibles.
Vous trouverez la cause dans le fichier journal du serveur Anveo qui est automatiquement créé dans le sous-dossier TransferANVEOServiceTierLog. Si aucun journal n’est disponible dans le dossier journal, veuillez ouvrir l’Observateur d’événements Windows pour plus d’informations.

Cause 1 – Droits manquants

Le service n’a pas d’utilisateur avec des droits d’administrateur local. Dans le journal des événements Windows, vous trouverez le message d’erreur suivant :
Le service ne peut pas être démarré. Système. Exception : HTTP ne pouvait pas enregistrer l’URL http…..

Solution 1

Donner à l’utilisateur du service Anveo les droits d’administrateur Windows pour la machine locale.

Cause 2 – Certificat non trouvé

Message d’erreur :
Si vous avez choisi d’utiliser votre propre certificat, le serveur Anveo ne peut pas trouver votre certificat.

Solution 2

Vérifiez l’empreinte de votre pouce dans votre fichier de configuration :

L’empreinte du pouce doit être identique à celle indiquée sur votre certificat.

Ajouter un Snap-In de certificat :

Ouvrez votre certificat :

Comparez votre Thumbprint ici avec votre configuration dans le fichier de configuration d’Anveo Server.

Si vous avez utilisé le copier-coller pour transférer la valeur, assurez-vous qu’il n’y a pas de caractère caché au début ou à la fin de l’empreinte du pouce.