Foire aux questions / Anveo Mobile App / Échec de l’installation d’Anveo Delta Server
C'est une traduction automatique. Le message original est disponible en Anglais.

Échec de l’installation d’Anveo Delta Server

Symptôme

Anveo Delta Server ne peut pas être installé dans Anveo Setup in Microsoft Dynamics montrant un des messages d’erreur suivants.

  • L’utilisateur n’a pas la permission d’effectuer cette action.
  • CLR est désactivé sur le serveur SQL Server. Activez CLR et réessayez.

Cause

L’utilisateur du serveur SQL n’a pas la permission d’exécuter l’instruction RECONFIGURE affichant le message d’erreur suivant :

Solution 1 – Donner les droits « sysadmin » avant l’installation

  • Ouvrez SQL Server Management Stuido et donnez à votre utilisateur SQL les droits d’administrateur système pour l’installation.

A) Pour Dynamics 2013 et les versions plus récentes, c’est l’utilisateur du service Microsoft Dynamics Server qui est utilisé. La valeur par défaut est NETWORK SERVICE.

Configurez sysadmin directement dans SQL Server Management Studio :

B) Pour Microsoft Dynamics NAV 2009 R2, l’utilisateur SQL Server est l’utilisateur que vous avez configuré dans Anveo Setup.

C) Toutes les versions de Microsoft Dynamics : Si vous avez configuré un utilisateur dédié dans la fonction GetSQLConnectionInformation in codeunit ACF App Events, donnez les droits d’administrateur système pour cet utilisateur.

  • Relancez l’installation d’Anveo Delta Server.
  • Pour des raisons de sécurité, supprimez les droits syadmin pour l’utilisateur après l’installation.

Solution 2 – Activer CLR manuellement dans SQL Server Management Studio

(Anveo Client Suite 6.01 et versions ultérieures)

  1. Open SQL Server Management Studio avec un utilisateur disposant des droits d’administrateur système.
  2. Exécutez la requête suivante :
sp_configure 'clr enabled', 1; RECONFIGURE;